Menu

An Existing Connection Was Forcibly Closed by the Remote Host


Symptom

I can send API requests using curl or Postman, but when I use my existing integration the application fails with an exception that reads, "An existing connection was forcibly closed by the remote host."

Applies To

  • TLS 1, 1.1, 1.2
  • 400 Error
  • HTTP Request

Resolution

Ensure you are using the correct TLS version by making an HTTP request to the following URL https://api.nexmo.com/tlsverification from your application. This end-point will return a 200 OK if the application correctly supports TLS v 1.2 and a 400 error if not.

Cause

It is possible that your application is using a deprecated TLS version when sending HTTPs requests to Vonage APIs. Note that legacy TLS version 1 and 1.1 were permanently disabled for all public endpoints as of 21 August 2018, due to serious security vulnerabilities in these protocols.

Was this article helpful?
0 out of 0 found this helpful
Follow
Have more questions? Submit a request